[MS4W-Users] MS4W 3.0.5 - 500 Internal Server Error

Donald Kerr donald.kerr at dkerr.co.uk
Sat May 26 04:47:36 EST 2012

I'm getting an issue with this version.

I uninstalled Apache, renamed my old MS4W directory and uncompressed the new
zip file to my D drive. Edited httpd.conf to listen on port 81 then
installed Apache via the bat file.

So far, so good. http://localhost:81/ in a browser brings up the default
page as expected.

http://localhost:81/cgi-bin/mapserv.exe on its own produces a "500 Internal
Server Error" rather than the expected "No query information to decode.
QUERY_STRING not set."

On running mapserv.exe directly from the command line, I am getting "The
procedure entry point gzdirect could not be located in the dynamic link
library zlib.dll." If I run the old mapserv.exe from the command line, I get
the expected "The script can only be used to decode form results and should
be initiated as a CGI process via a httpd server."

If I run the new install as part of my whole setup, including OpenLayers at
the client end, I just get a series of 500 Internal Server Errors for each
tile request.

Can anyone advise please?



More information about the MS4W-Users mailing list