[MS4W-Users] MS4W 3.0.5 - 500 Internal Server Error

Donald Kerr donald.kerr at dkerr.co.uk
Sat May 26 05:38:51 EST 2012

zlib1.dll is missing from the new Apache/cgi-bin directory. I copied over
the file from the old set up and am no longer getting the "500 Internal
server Error" for my raster layers. They seem to be working ok.

However, I have a PostGIS layer that seems to crash mapserv.exe. I am
getting the following error from Windows (XP SP3):

"Mapserv.exe has encountered a problem and needs to close."

Further details are:

szAppName : mapserv.exe     szAppVer :     szModName : unknown     
szModVer :     offset : 00000041



-----Original Message-----
From: ms4w-users-bounces at lists.maptools.org
[mailto:ms4w-users-bounces at lists.maptools.org] On Behalf Of Donald Kerr
Sent: 26 May 2012 10:48
To: 'ms4w'
Subject: [MS4W-Users] MS4W 3.0.5 - 500 Internal Server Error

I'm getting an issue with this version.

I uninstalled Apache, renamed my old MS4W directory and uncompressed the new
zip file to my D drive. Edited httpd.conf to listen on port 81 then
installed Apache via the bat file.

So far, so good. http://localhost:81/ in a browser brings up the default
page as expected.

http://localhost:81/cgi-bin/mapserv.exe on its own produces a "500 Internal
Server Error" rather than the expected "No query information to decode.
QUERY_STRING not set."

On running mapserv.exe directly from the command line, I am getting "The
procedure entry point gzdirect could not be located in the dynamic link
library zlib.dll." If I run the old mapserv.exe from the command line, I get
the expected "The script can only be used to decode form results and should
be initiated as a CGI process via a httpd server."

If I run the new install as part of my whole setup, including OpenLayers at
the client end, I just get a series of 500 Internal Server Errors for each
tile request.

Can anyone advise please?



MS4W-Users mailing list
MS4W-Users at lists.maptools.org

More information about the MS4W-Users mailing list