[OSRS-PROJ] Compiling proj4 fails on RedHat 7.3

Mike Schmidt mike at sepia.com
Wed Jul 24 21:49:32 EDT 2002

I've tried to compile proj4 (latest version) on RedHat linux 7.3. I've 
tried this with both GCC2.96 and GCC3.1, with the same results. On RedHat 
6.2, this procedure works perfectly.

It's a stock install, and I do what the instructions say:


Here's the tail end of the response:

creating src/Makefile
make[1]: Leaving directory `/home/mike/develop/proj4/src'
make[1]: Entering directory `/home/mike/develop/proj4/src'
/bin/sh ../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I. 
-DPROJ_LIB=\"/usr/local/share/proj\"    -g -O2 -c PJ_aeqd.c
libtool: ltconfig version `' does not match ltmain.sh version `1.3.4'
Fatal configuration error.  See the libtool docs for more information.

My default shell is tcsh in all cases.

It looks like ltconfig is not passing the $VERSION variable correctly to 

I have checked both files, they clearly have VERSION=1.3.4 set.

What's the problem with RedHat 7.3?


Mike Schmidt                        Systèmes Scientifiques SEPIA
President                              SEPIA Scientific Systems
Tel: 450-358-2266                  100 Richelieu, suite 2000
Fax: 450-358-2267                 Saint-Jean-sur-Richelieu
e-mail: mike at sepia.com        Québec, Canada J3B 6X3
http://www.sepia.com             http://www.intello.com

This email message is for the sole use of the intended recipient(s)
and may contain confidential and privileged information.
Any unauthorized review, use, disclosure or distribution is prohibited.
If you are not the intended recipient, please contact the sender by
reply email and destroy all copies of the original message.
To reply to our email administrator directly, select the following
<mailto:postmaster at sepia.com>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.maptools.org/pipermail/proj/attachments/20020724/48d6b247/attachment.html

More information about the Proj mailing list