[Proj] Error compiling proj on Solaris: Undefined symbol

Adrian Holovaty adrian.holovaty at wpni.com
Fri May 19 14:04:04 EDT 2006


I'm trying to install proj on Solaris so I can use it with PostGIS, but it 
won't compile. Here's the relevant error I get when I run "make".


gcc -g -O2 -o .libs/proj proj.o gen_cheb.o p_series.o  ./.libs/libproj.so -lm 
Undefined                       first referenced
 symbol                             in file
.LLC4                               ./.libs/libproj.so
.LLC8                               ./.libs/libproj.so
ld: fatal: Symbol referencing errors. No output written to .libs/proj
collect2: ld returned 1 exit status
make[2]: *** [proj] Error 1
make[2]: Leaving directory `/home/holovatya/proj-4.4.9/src'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/home/holovatya/proj-4.4.9/src'
make: *** [all-recursive] Error 1


The same error has been pointed out here:


Those threads suggested a couple of solutions, all of which I've tried.

I've tried removing the C_NAMESPACE qualifiers, as suggested here:


I've tried setting CFLAGS, as suggested here:


I've tried using a custom version of libtool, as suggested here:


The same compilation error happens every time with each of those suggested 

I'm using:

    proj 4.4.9
    Solaris 9
    GCC 3.2
    make 3.80

Please help me get proj to compile. Thanks for any and all help, and let me 
know if I left any important information out of this report.


Adrian Holovaty

More information about the Proj mailing list