[TinyOWS-users] xml isn't valid

Zack Galbreath zack.galbreath at gmail.com
Thu Oct 28 16:19:53 EST 2010

Hi list,

I'm trying to make it so that users can create and save features on an 
OpenLayers map.  I downloaded the example 
(http://tinyows.org/trac/wiki/OpenLayersHowToTransactional), ran it 
locally, and it works fine.  Unfortunately, I run into problems when I 
edit the example to use my own locally running TinyOWS server.

A (probably?) unrelated issue is that I can't load the Frida data into 
postgres.  When I run:

shp2pgsql -s 31467 -I gruenflaechen.shp frida | psql -U postgres -d tinyows

I encounter the following output:

Unable to convert data value to UTF-8 (iconv reports "Invalid or 
incomplete multibyte or wide character").  Current encoding is "UTF-8". 
Try "LATIN1" (Western European)...  At this point 
"/usr/lib/cgi-bin/tinyows --check" reports no available layers.

Anyway, I use the France data from the read-only example instead, making 
sure to specify writable="1" in config.xml.  When I try to save a 
feature I get the follow response in Firebug: "xml isn't valid".  In the 
log file the error is expanded to:

[ERROR] Element '{}france': This element is not 
expected. Expected is one of ( {http://www.opengis.net/gml}_Feature, 
{http://www.opengis.net/gml}FeatureCollection, ... (snip)
[ERROR] xml isn't valid

So I have two questions for you all:
1.  What am I doing wrong that's preventing me from saving features to 
my local installation of TinyOWS?
2.  How do I create my own empty feature database to use with TinyOWS & 

My version of libxml2 is the latest that ships with ubuntu/lucid: 
2.7.6.  Please let me know if I failed to include any important information.


More information about the TinyOWS-users mailing list