[TinyOWS-users] Problem inserting features

Brian May bmay at mapwise.com
Mon Sep 19 15:22:41 EST 2011

Getting TinyOWS to work has been a long and winding road - still no 
success - and almost ready to give up. Here's the latest on what I have 
tried and the results.

I ended up trying it out on linux and got further down the road, but 
different problems. I compiled it from source from SVN. I can insert 
features via QGIS and OpenLayers now, but the inserted features do not 
have any geometry (confirmed via checking out the table in postgres). 
And I can see existing features in QGIS that I manually added via a 
direct connect to postgres, but not in OpenLayers! I have been running 
down a lot of rabbit holes trying to get this figured out, burning a lot 
of time and I could really use some help.

Also, I may have found a few bugs in the process. For example, if you 
have two geometry columns in your table, and do not inform tinyows of 
the additional geometry column via the config file, it produces a 500 
error when testing from the browser. Does tinyows expect the_geom vs. 
wkb_geometry? Tried both and it seems to operate the same, except when 
you have them both there at the same time.

I don't remember if this is in the docs, but you must have a record in 
the geometry_columns table for tinyows to recognize the layer at all - 
you can have your config all set up right, and it just won't show the 
layer as being available.

If you change the geometry column name in your table and the geometry 
column name in the geometry_columns table don't match - doing ./tinyows 
--check produces the following error:
row number 0 is out of range 0..-1
tinyows: src/struct/buffer.c:254: buffer_add_str: Assertion `str' failed.

Is there any reason why having your data in 900913 projection would be a 
problem? Wasn't my first choice, but I figured i could eliminate 
projection problems that way since the map is in 900913.

Also, not sure why, but after some change I made, the url 
is producing a much more terse output than before. Haven't figured out 
what it is yet, although if I take out my custom layer, and just have 
the france demo, the verbose output comes back.

If its easier to help debug this, I can open it up to the outside world 

Any help would be greatly appreciated.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.maptools.org/pipermail/tinyows-users/attachments/20110919/adfccbfa/attachment.htm 

More information about the TinyOWS-users mailing list