[Cartoweb-users] Can't load mapscript library - Suse 10

Pebble Puppy pebble_puppy at hotmail.com
Wed Apr 5 23:36:53 EDT 2006


Thanks for the suggestions Alexandre,

I did as you suggested, copying php.info into cartoweb3/htdocs and then 
calling it via the browser.  When I do this, it returns the tables of 
information, but at the very top of the page, above the tables I do indeed 
see, "WARNING: can't load mapscript library".  Within the tables, there is 
no mention of MapScript as a table or within an existing table.

When I run 'http://localhost/cartoweb/test.php' I do not get the "can't load 
mapscript library" at the top of the tables, but there is still no mention 
of Mapscript anywhere on the page.  The test.php is simply:


  if (PHP_OS == "WINNT" || PHP_OS == "WIN32")


This file came from 

I also did as you suggested, changing the 'php_mapscript' in php.ini to be 

I'm sure it's some simple error on my part, but I too thick-headed to see 
where the problem is.  If you have any other ideas I would greatly 
appreciate them.  Thank you again for your earlier thoughts.

Regards, Robert

>From: Alexandre Saunier <alexandre.saunier at camptocamp.com>
>To: Pebble Puppy <pebble_puppy at hotmail.com>
>CC: cartoweb-users at lists.maptools.org
>Subject: Re: [Cartoweb-users] Can't load mapscript library - Suse 10
>Date: Wed, 05 Apr 2006 20:36:02 +0200
>Pebble Puppy wrote:
>>When I run 'index.php' from my browser where 'index.php' contains:
>>     echo phpinfo();
>>the browser returns several tables of information regarding PHP 5.1.2
>What if you copy (or symlink) the file info.php located in 
>cartoweb3/scripts into cartoweb3/htdocs and call it via
>Does it return a "WARNING: can't load mapscript library"?
>Can you find a "MapScript" table in the displayed phpinfo?
> > In the /usr/local/apache2/php/php.ini file I have a line:
> > extension=php_mapscript
>Isn't there a ".so" extension missing?

More information about the Cartoweb-users mailing list