[Cartoweb-users] failure - cannot find

Kenton Williams Kenton_Williams at umit.maine.edu
Thu Apr 20 12:13:48 EDT 2006


I modified my layers.ini file so that it is now:

layers.root.className = LayerGroup
layers.root.children = AllMaine, Urban, Wetlands, boundarylines, water, roads
layers.root.rendering = tree

layers.AllMaine.className = Layer
layers.AllMaine.label = All of Maine

layers.Urban.className = Layer
layers.Urban.label = Urban Areas

layers.Wetlands.className = Layer
layers.Wetlands.label = Wetlands

layers.boundarylines.className = LayerGroup
layers.boundarylines.label = Boundary Lines
layers.boundarylines.children = TownLines, Counties
layers.boundarylines.rendering = tree

layers.TownLines.className = Layer
layers.TownLines.label = Town Lines

layers.Counties.className = Layer
layers.Counties.label = Counties

layers.water.className = LayerGroup
layers.water.label = Water Bodies
layers.water.children = BigWater, MedScaleWater, SmScaleWater
layers.water.aggregate = true

layers.BigWater.className = Layer
layers.BigWater.label = Large Waterbodies

layers.MedScaleWater.className = Layer
layers.MedScaleWater.label = Medium Detail Waterbodies

layers.SmScaleWater.className = Layer
layers.SmScaleWater.label = High Detail Waterbodies

layers.roads.className = LayerGroup
layers.roads.label = Roads
layers.roads.rendering = tree
layers.roads.children = LocalRds, SecRds, SpecRds, Interstate

layers.LocalRds.className = Layer
layers.LocalRds.label = Local Roads

layers.SecRds.className = Layer
layers.SecRds.label = Secondary Roads

layers.SpecRds.className = Layer
layers.SpecRds.label = Special Roads

layers.Interstate.className = Layer
layers.Interstate.label = Interstate

All of the layers are present in my mapfile, even the same case (ex: TownLines rather than townlines).  I get the exact same error message.  I tried deleting the boundarylines layerGroup entirely to have the layers shown independently in the layer
tree.  In spite of the fact that there is absolutely no mention of boundarylines child layer in the layers.ini file, I STILL get the error that the child layer boundarylines cannot be found.  Do you have to re-run the cw3setup.php every time after
making changes to the layers.ini file?

I have attached both my mapfile and my layers.ini file for reference.

Thanks very much for your assistance!

Kenton W.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: layers.ini
Type: application/octet-stream
Size: 1589 bytes
Desc: not available
Url : http://lists.maptools.org/pipermail/cartoweb-users/attachments/20060420/58b2dc57/layers.obj
-------------- next part --------------
A non-text attachment was scrubbed...
Name: cgd_mapfile.map
Type: application/octet-stream
Size: 5825 bytes
Desc: not available
Url : http://lists.maptools.org/pipermail/cartoweb-users/attachments/20060420/58b2dc57/cgd_mapfile.obj

More information about the Cartoweb-users mailing list