[Chameleon] chameleon 2.2beta1 - cannot open session mapfile

Jacob Delfos jacob.delfos at maunsell.com
Mon May 9 20:48:26 EDT 2005


Removing the keymap makes it work, so it must be to do with that.


-----Original Message-----
From: Paul Spencer [mailto:pspencer at dmsolutions.ca] 
Sent: 9 May 2005 22:11
To: Bart van den Eijnden
Cc: chameleon at lists.maptools.org; jacob.delfos at maunsell.com
Subject: Re: [Chameleon] chameleon 2.2beta1 - cannot open session mapfile

This is a change in mapserver version that is generating the error 
message.  Someone added validation of extents (minx<maxx, miny<maxy) and 
in doing so has broken some parts of Chameleon - I noticed this first 
with the KeymapDHTML, which I fixed, but I hadn't seen it anywhere else.

Something is allowing extents to be set on the keymap object that do not 
meet the new constraints, but I'm not sure where this happens ... unless 
your widget tags are somehow wrong - I mean the samples in this case.

I'll take a quick look today.


Bart van den Eijnden wrote:
> Hi Jacob,
> I ran into this as well and reported this to Paul off-list. Must be a bug. I only noticed that the keymap did not work anymore after submit and that I had a javascript error. I did not check php logs but this must be the same error.
> Best regards,
> Bart
> Bart van den Eijnden
> Syncera-ITSolutions
> Postbus 270
> 2600 AG  DELFT
> tel.nr.: 015-7512436
> email: BEN at Syncera-ITSolutions.nl
>>>>"Jacob Delfos" <jacob.delfos at maunsell.com> 05/09/05 03:41am >>>
> Hi All,
> I was just testing the 2.2beta1, and received this error when the page reloads after submitting:
> · No valid map object to write.
> ·Unable to access map [C:/web/tmp/sess_427ebcc0029e9/1115602113-1985.map].. Check to see that the file exists and/or that the path and filename are spelled correctly
> my PHP log says:
> [09-May-2005 09:37:01] PHP Warning:  [MapServer Error]: loadReferenceMap(): Given reference extent is invalid.
>  in C:\chameleon\epra\htdocs\common\wrapper\map_session.php on line 215
> [09-May-2005 09:37:01] PHP Warning:  Failed to open map file C:/web/tmp/sess_427ebebb99de8/1115602620-6194.map in C:\chameleon\epra\htdocs\common\wrapper\map_session.php on line 215
> That happens on submit. I was using the sample_enhanced_jsapi.phtml (I moved the file and the paths to suit my directory structure, but this shouldn't matter). First page loads fine. Haven't changed my config file since previous (working) version, so my paths should be ok.
> Javascript navigation was working, but on submit the error occurs. The session ID in the first loaded page matches the directory that was created. The path and file it is referring to exist (file has content), so something goes wrong when the page is loaded. Because it can't find it, it actually creates a new directory (new session).
> Anybody have any ideas?
> regards,
> Jacob
> Maunsell Australia Pty Ltd
> 629 Newcastle Street, WA 6007
> PO Box 81, WA 6902
> Leederville 
> Western Australia
> ABN 20 093 846 925
> Tel     + 61 8 9281 6185
> Fax    + 61 8 9281 6297
> jacob.delfos at maunsell.com
> _______________________________________________
> Chameleon mailing list
> Chameleon at lists.maptools.org
> http://lists.maptools.org/mailman/listinfo/chameleon

|Paul Spencer                           pspencer at dmsolutions.ca   |
|Applications & Software Development                              |
|DM Solutions Group Inc                 http://www.dmsolutions.ca/|
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.maptools.org/pipermail/chameleon/attachments/20050510/5ac985f3/attachment.html

More information about the Chameleon mailing list