[FGS] FGS Configuration Issue

Guillaume Dallaire gdallaire at dmsolutions.ca
Thu Jul 7 11:02:38 EDT 2005

Hi David,

On Wed, 2005-07-06 at 22:41 -0500, David Fawcett wrote: 
> I am in the process of configuring FGS on FC3.  I installed the gmap
> demo and I am trying to use the demo to confirm that I have everything
> configured properly.
> When I hit the page  , the

this is not the cause of the problem, but the correct URL is:   (-demo missing)

> legend and header labels load, but I get two messages in the map
> window:
> Warning: [MapServer Error]: msSaveImageGD(): Unable to open file
> /tmp/ms_tmp/112070747044661.gif for writing in
> /mapserver/gmap/apps/gmap-ms40/htdocs/gmap75.inc.php on line 552
> Fatal error: Failed writing image to /tmp/ms_tmp/112070747044661.gif
> in /mapserver/gmap/apps/gmap-ms40/htdocs/gmap75.inc.php on line 552
> I haven't worked with mapscript much, but this indicates to me that
> the permissions are not set to allow the webserver user to write to
> this directory.  I CHMODed the directory permissions to 666 and then
> 777 and I still get the errors.
> Anyone have recommendations on where I should look next?  

It looks like the ms_tmp directory in $FGS_HOME/tmp is missing. It is
normally created by the mapserver module's installer. Run:

$ mkdir $FGS_HOME/tmp/ms_tmp

and make sure that the user running FGS can write in it.

I just tried the gmap-demo FGS self-install file on a Fedora Core 3 box
and all went perfectly, did you install this file :

linux-i386.bin  ?

Did you install is as a normal user or as root ?


  Guillaume Dallaire               gdallaire at dmsolutions.ca
  DM Solutions Group             http://www.dmsolutions.ca/

More information about the Foss-gis-suite mailing list