[FGS] Unable to load dynamic library

Samuel Smith ssmith at refractions.net
Mon Jun 27 10:55:10 EDT 2005

Raise the inexperience flag !!! My last post re: unable to write to a
given file in a given directory was a simple matter of permissions. I
had probably installed FGS-chameleon as root leavign the web user
'apache' out in the cold.

Otherwise the compatability libraries to adjust to fedora core 3 that
you Guillaume suggested in his last post worked wonderfully -- I (and
probably others) look forward Fedora Core compatability soon :) 

Thanks for all your help - Samuel

-----Original Message-----
From: Guillaume Dallaire [mailto:gdallaire at dmsolutions.ca] 
Sent: Saturday, June 25, 2005 4:35 AM
To: Samuel Smith
Cc: foss-gis-suite at lists.maptools.org
Subject: Re: [FGS] Unable to load dynamic library

On Sat, 2005-06-25 at 06:02, Samuel Smith wrote:
>  (Am Linux ~Newbie)
>         A similiar issue came up in ~May 2005 from Bart Wood but
>         unresolved on the list.
>         Am facing the following error:
>         Warning: dl(): Unable to load dynamic library
>         '/opt/fgs/www/lib/php4/php_mapscript.so'
>         - /opt/fgs/lib/libnetcdf.so:
>         cannot restore segment prot after reloc: Permission denied
>         in /opt/fgs/apps/chameleon-2.0/htdocs/chameleon.php on line 
> 432
>         Fatal error: Call to undefined function: ms_reseterrorlist()
>         in /opt/fgs/apps/chameleon-2.0/htdocs/chameleon.php on line 
> 553
>         ldd on php_mapscript.so appears clean -- and the ldd on
>         ldd /opt/fgs/lib/libnetcdf.so returns "statically linked" --
>         seems fine
>         I am on Fedora Core 4 (to make it difficult/fun).
>         Suggestions/Comments are appreciated - Will report success /
>         failures
>         back to the list.

Hi Samuel,

on Fedora Core 4, I had to install this RPM:


in order to get the FGS's Chameleon demo working.

If it still not work, please send me this informations (output):

$ ldd $FGS_HOME/www/lib/php4/php_mapsript.so

and from what file you did the installation (self-installer file name).


More information about the Foss-gis-suite mailing list