[FGS] FGS Installation

Dylan Rawlins dylan at mapserver.co.za
Tue Jul 20 12:34:50 EST 2010

The postgis-lib module is there.....

agg-lib             gd-lib            libiconv-base   ming-lib
php_gettext-module     php_wddx-module          python-base
apache-base         geos-lib          libpng-lib      mod_python-module
php_http-module        php_xmlrpc-module        python_mapscript-module
chameleon-base      gettext-base      libssh2-lib     openlayers-base
php_imagick-module     php_xsl-module           python_mx-module
curl-lib            gmap-demo         libstdc++-lib   openssl-lib
php_mysql-module       postgis-lib              python_pil-module
expat-base          imagemagick-base  libungif-base
pecl_uploadprogress-module  php_odbc-module        postgresql-lib
freetype-lib        jpeg-lib          libxml2-base    php-base
php_ogr-module         postgresql-server        studio-base
fusion-base         kamap-base        libxslt-lib     php_curl-module
php_pgsql-module       proj4_epsg42xxx-support  tiff-lib
gdal-base           libgcc-lib        mapserver-base  php_dbase-module
php_postscript-module  proj-lib                 tilecache-base
gdal_python-module  libgeotiff-lib    mapserver-php   php_ftp-module
php_ssh2-module        pslib-base               tinyows-server

According to some of the reading that I have done on the web the
lwpostgis.sql file should have been installed and it should appear in
the fgs/apps/pgsql/share/ directory

I have also tried to do a separate install of postgresql postgis etc but
it fails on the "make check" of the GEOS installation. Is there any
simple way to get PostGIS installed - I have literally been trying for 2


Is PostGIS installed in your FGS?

Go to your FGS installation root directory
$ ls etc/fgs/pkgs/

What is the output of that?

If you don't see postgis-lib in that, install it doing:
$ . setenv.sh
$ fgs install postgis-lib

Does that work?

Note that installing another postgresql on your server may cause problem 
because it will probably end up running on the same port as FGS's 
PostgreSQL. You can change FGS port in 


On 10-07-20 11:22 AM, Dylan Rawlins wrote:
> Hi,
> I get this far ...
> Go to your FGS installation root directory and do ". setenv.sh"
> Do "FGS start"
> Execute : createdb yourdb
> Execute : createlang plpgsql yourdb
> Execute : psql -f ..\share\contrib\lwpostgis.sql yourdb
> and I get an error saying that it cannot locate the lwpostgis.sql file.
> I searched my entire hard drive and can't find the file. I also looked
> for any *.sql file that would relate to postgis and there is nothing. I
> force installed a lower version of postgis (1.3.5) and the lwpostgis
> file was there. But then it won't work with postgresql 8.4. So I force
> installed 8.3 and then nothing worked - couldn't even get a connection
> to the DB. So I have gone back to the original versions that I
> downloaded and am stuck wiht the same problem.
> Any ideas,
> Thanks
> Dylan
> _______________________________________________
> Foss-gis-suite mailing list
> Foss-gis-suite at lists.maptools.org
> http://lists.maptools.org/mailman/listinfo/foss-gis-suite

Julien-Samuel Lacroix
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.maptools.org/pipermail/foss-gis-suite/attachments/20100720/08950547/attachment.htm 

More information about the Foss-gis-suite mailing list