[FWTools] Open EV crashes when opening shape files

Rengifo Ortega rengifoo at yahoo.de
Fri Aug 8 09:14:20 EDT 2008

Hello Frank, thanks a lot for the quick answer :-). I solved the
problem by building up the topology of the  multipart shapefile in GRASS
GIS. It seems to be that the a data I am working with still had some
topological mistakes even if I exported it from a SDE geodatabase...
Now it works perfectly
Greets and nice weekend 
Rengifo Ortega 

On Thu, 2008-08-07 at 10:54 -0400, Frank Warmerdam wrote:
> Rengifo Ortega wrote:
> > Hello  I am pretty new but very interested in learning more about
> open 
> > EV. I do not know if this is a bug... but whenever I try to open
> shapes 
> > in Open EV it collapses and closes. Have someone heard about the
> same 
> > problem and its possible solutions.
> Rengifo,
> Can you explain how large you mean by large?
> OpenEV loads all the feature data from shapefiles into memory and the
> in memory representation can be substantially larger than the on disk
> representation.  It is also possible there is something particular
> about
> the geometries in your big shapefile, and one of them is crashing the
> tesselator.  This does happen sometimes.  Launching OpenEV with the -h
> switch *might* help if this is the issue.
> Generally, I'd like to establish whether the issue is with running out
> of
> memory or some OpenGL thing.
> Best regards,
> -- 
Rengifo Ortega <rengifoo at yahoo.de>

More information about the FWTools mailing list