[FWTools] Problem running mapserv binary from cgi-bin

Frank Warmerdam warmerdam at pobox.com
Thu Aug 21 16:08:45 EDT 2008

Roger André wrote:
> Hi Frank,
> Thanks for the suggestion.  I tried copying over the mapserv from 
> bin_safe, restarted apache and gave it a shot.  I get a different error, 
> but still no joy.
> [Thu Aug 21 12:48:20 2008] [error] [client <>] 
> /var/www/cgi-bin/mapserv: line 7: 
> /home/randre/local/FWTools-2.0.6/fwtools_env.sh: Permission denied
> [Thu Aug 21 12:48:20 2008] [error] [client <>] 
> Premature end of script headers: mapserv
> I've set the perms to 777 for fwtools_env.sh, but it still doesn't 
> work.  I wonder if this could be happening because of the install under 
> my home dir?


Yes, likely.  On most modern linux systems read permissions into users
home directories is limited to the user and root, so an apache process
would generally not be able to get there.  Often the following will
resolve the problem - or you may find it preferrable to install FWTools
somewhere less protected (like /opt).

   chmod go+rx $HOME/.

Best regards,

I set the clouds in motion - turn up   | Frank Warmerdam, warmerdam at pobox.com
light and sound - activate the windows | http://pobox.com/~warmerdam
and watch the world go round - Rush    | Geospatial Programmer for Rent

More information about the FWTools mailing list