[FWTools] Problem with memory allocation using FWTools 2.0.4

"SAEZ Laurent - CETE Méditerr./DI/ETER" Laurent.Saez at equipement.gouv.fr
Thu Jan 17 03:23:53 EST 2008


I've tried my script with FWTools 2.0.5.
I've got the same problem. It occures at the end of the process (near 100%).

I just create an OSGeo userid to submit a bug report.
I tried to submit a new ticket but I was logged out each time I clicked on "submit".
I will try later.

Thanks a lot


-----Message d'origine-----
De : Frank Warmerdam [mailto:warmerdam at pobox.com]
Envoyé : mercredi 16 janvier 2008 16:47
À : "SAEZ Laurent - CETE Méditerr./DI/ETER"
Cc : fwtools at lists.maptools.org
Objet : Re: [FWTools] Problem with memory allocation using FWTools 2.0.4

SAEZ Laurent - CETE Méditerr./DI/ETER wrote:
> Thanks Frank for your quick response,
> I have 100 shape files produced with Arc Analyst by a friend of mine.
> I have to do some changes :
> - rename the field GRIDCODE to CODE_PENTE,
> - add a new field called PENTE whose value depends on CODE_PENTE.
> I'm not at all a programmer.


You are now!
> I have been guided by your file vec_tr.py.
> Thanks for your help !

I skimmed the script and it looks reasonable.  I think there have been
some significant changes in the shapefile driver between 2.0.3 and 2.0.4
though I'm surprised at the problem you encounter since 2.0.4 was
essentially the release version of GDAL.  If you can submit a bug report
against GDAL including a pointer to all the details to reproduce your
problem that would be appreciated.

In the meantime, I'm going to produce an FWTools 2.0.5 today to see if
the problem persists.

Best regards,
I set the clouds in motion - turn up   | Frank Warmerdam, warmerdam at pobox.com
light and sound - activate the windows | http://pobox.com/~warmerdam
and watch the world go round - Rush    | President OSGeo, http://osgeo.org

More information about the FWTools mailing list