[ka-Map-users] ka-Map-users Digest, Vol 56, Issue 7

Bistrais, Bob Bob.Bistrais at maine.gov
Mon Dec 21 16:20:12 EST 2009

I've started looking into OpenLayers, although I'll admit to being a
total newbie to it.  I was able to get one of our WMS layers to work in
a very rudimentary application, and the speed was pretty good.

I found something else in the Ka-Map arena- there is a wmsLayer.js file,
which looks like it should do what I am interested in.  I don't quite
understand how to implement it, though.  I've emailed Paul at DM
Solutions (the author), but have not heard back yet.  Has anyone used
this, and if so, would you have any advice on how to implement it?


-----Original Message-----
From: ka-map-users-bounces at lists.maptools.org
[mailto:ka-map-users-bounces at lists.maptools.org] On Behalf Of
ka-map-users-request at lists.maptools.org
Sent: Friday, December 18, 2009 12:00 PM
To: ka-map-users at lists.maptools.org
Subject: ka-Map-users Digest, Vol 56, Issue 7

Send ka-Map-users mailing list submissions to
	ka-map-users at lists.maptools.org

To subscribe or unsubscribe via the World Wide Web, visit
or, via email, send a message with subject or body 'help' to
	ka-map-users-request at lists.maptools.org

You can reach the person managing the list at
	ka-map-users-owner at lists.maptools.org

When replying, please edit your Subject line so it is more specific than
"Re: Contents of ka-Map-users digest..."

Today's Topics:

   1. Re: Improving ka-map speed with non-cached WMS? (percy)
   2. Re: ka-Map-users Digest, Vol 56, Issue 6 (Bistrais, Bob)


Message: 1
Date: Thu, 17 Dec 2009 09:23:20 -0800
From: percy <percyd at pdx.edu>
Subject: Re: [ka-Map-users] Improving ka-map speed with non-cached
To: ka-map-users at lists.maptools.org
Message-ID: <4B2A6908.80002 at pdx.edu>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed

Bob, let me second Steve's good advice, use Openlayers as your client!

We switched several years ago, but we still use kamap as our tiling
engine. OL will let you call a WMS as a single call (singleTile: true),
call mapserver directly for uncached data, etc, etc.

> Date: Wed, 16 Dec 2009 22:56:55 -0500
> From: Stephen Woodbridge <woodbri at swoodbridge.com>
> Subject: Re: [ka-Map-users] Improving ka-map speed with non-cached
> 	WMS?
> To: "Bistrais, Bob" <Bob.Bistrais at maine.gov>
> Cc: ka-map-users at lists.maptools.org
> Message-ID: <4B29AC07.40402 at swoodbridge.com>
> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
> Personally, I have switched all my application building over to 
> OpenLayers because is has all the functionality of ka-map on the 
> client side and will support ka-maps precache script if you want to 
> use it on the server-side and you can mix layers in tiles, with a 
> single-tile mode which just draws a single large image filling the 
> view port like you are requesting. Also OpenLayers has a very active 
> community and is still very active on the development side of things.
> http://openlayers.org/
> -Steve
> Bistrais, Bob wrote:
>> I'm looking into doing this, and may well be asking for further
>> Taking it from another angle- is it possible to bypass or disable 
>> ka-map's tiling for the image layers?  I don't mean precached vs.
>> nocache, what I mean is, is it possible to draw the WMS data directly

>> and without breaking it into tiles when ka-map renders it?  I'm 
>> asking because this seems to be what's slowing it down.  I can draw 
>> my WMS services in MapServer CGI mode and they're plenty fast.  
>> Likewise, using the same WMS services in ArcGIS or other platforms, 
>> they draw more quickly than with ka-map.

David Percy
Geospatial Data Manager
Geology Department
Portland State University


Message: 2
Date: Thu, 17 Dec 2009 12:41:47 -0500
From: "Bistrais, Bob" <Bob.Bistrais at maine.gov>
Subject: Re: [ka-Map-users] ka-Map-users Digest, Vol 56, Issue 6
To: <LeonMacNichols at gmail.com>,	<ka-map-users at lists.maptools.org>
<4EFF8BB964547748A07CA32961810C0415F32B5C at SOM-TEAQASMAIL1.som.w2k.state.
Content-Type: text/plain;	charset="us-ascii"

Hi Leon,

Are you only getting this error in IE 6?  Have you tried other browsers
and found the same error?  I'd suggest testing with Firefox and with the
Firebug plugin.  It's far more useful for debugging.  Also, check your
ms_error.txt file for any clues, it's usually located at


Message: 3
Date: Thu, 17 Dec 2009 05:55:37 -0800 (PST)
From: LeonMacN <LeonMacNichols at gmail.com>
Subject: [ka-Map-users]  Ka - Map in IE6
To: ka-map-users at lists.maptools.org
Message-ID: <26813324.post at talk.nabble.com>
Content-Type: text/plain; charset=us-ascii

Hi all..!!!

I'm just begining to use Ka - Map and so far it's a really great tool
but unfotunelly it's giving me problems when i try to use it in IE6; it
give me errors...

The error that give me is:

Message: 'this.kaMap.currentTool' is null or not an object'

Did somebody know why it's giving me this error...???

View this message in context:
Sent from the ka-map-users mailing list archive at Nabble.com.


ka-Map-users mailing list
ka-Map-users at lists.maptools.org

End of ka-Map-users Digest, Vol 56, Issue 7

More information about the ka-Map-users mailing list