[maplab-users] Maplab installation and configuration

Zak James zak4ms at gmail.com
Mon Aug 15 17:37:45 EDT 2005


If you know the relevant php extensions are loaded, you can comment
out the dl() calls in the maplab code and it should function properly.

Also note that there is a known problem with mapedit and the most
recent releases of php 4 and 5. Check the download page on
maptools.org for details


On 8/14/05, Ivan Kautter <ivankautter at hotmail.com> wrote:
> List subscribers,
> I have attempted to install and use maplab under my current Apache2
> installation (not ms4w), current mapserver installation, and current php
> installation as I installed all these components before I knew of maplab.
> In attempting to access the index page for maplab I get the error message
> that the session save path does not exist or is not writeable.  What I fail
> to understand is how the session save path would be accessible under the
> recommended ms4w installation if the path were "C:/tmp" as I think that
> would have to writeable for the web server.  Now if I set an absolute path
> for session save path in the php.ini file that should be accessible by the
> web server under my current configuration, I still get the same error.  So
> this is one issue that I cannot resolve.
> Further, in merely hunting around, I thought I would try the info.phtml file
> to see if that worked.  Unfortunately, the code in that file specifies the
> use of the dl() which I gave never gotten to work under Apache2.  Error
> message is the standard one for dl() may not be used in a multithread
> server, despite the fact that I have it enabled in php.ini.  I, of course,
> added the required extensions (php_dbase.dll and php_g2.dll) via the php.in
> file.  This seems to make no difference as the script in info.phtml seems to
> require the use of the dl() function.  Will this keep me from using maplab
> at all?
> I am wondering what the possible solution can be to these problems so that I
> can use maplab.
> I am running under Windows XP home using Apache 2, the lastest php 4,
> php_mapscript4.7.
> I have the maplab-2.2 folder residing directly under the Apache2 directory
> and the pages are accessible but not functioning properly as I stated above.
>    PHP is installed directly under C: directory.
> Thanks for any assistance that anyone can offer.
> Ivan Kautter
> _______________________________________________
> Maplab-users mailing list
> Maplab-users at lists.maptools.org
> http://lists.maptools.org/mailman/listinfo/maplab-users

Zak James
Applications and Software Development
DM Solutions Group Inc.

More information about the Maplab-users mailing list