[OSRS-PROJ] "projection initialization failure" Error

Michael DeChaine mdechaine at schaferdc.com
Wed Feb 21 11:27:35 EST 2001

Just a quick note to save someone else the trouble of solving the problem
that I had.

In short, when I ran the example from the man page, I got the following

$ proj +proj=utm +lon_0=112w -r
Rel. 4.4.2, 15 July 2000
projection initialization failure
cause: major axis or radius = 0 or not given
program abnormally terminated

It took a while for me to figure out that I needed to specify an ellipsoid.
So, the following example works:

$ proj +proj=utm +lon_0=112w -r +ellps=clrk66
45d15'33.1"    111.5w
460769.27       5011648.45

So, it works now, but isn't there a default ellipsoid?  Well, after some
digging through the source (thank goodness for open source!) I found I
needed to set the PROJ_LIB environment variable so that proj would know
where to find the "proj_def.dat" file.  Then, it would find that clrk66 is
the default ellipsoid.  Might be nice to have a warning message that it
can't find the file, but I realize that would probably just add clutter to
the screen or output files.

Could the man page be changed to add the "+ellps=clrk66" parameter to the
example?  That might help some folks new to proj.

Anyway, many thanks for the proj library.  Looks like I'm going to be using
it quite a bit.

- Michael

PROJ.4 Discussion List
See http://www.remotesensing.org/proj for subscription, unsubscription
and other information.

More information about the Proj mailing list